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1. Introduction
CNC Transfer enables a PC to communicate with any CNC machine that has a serial
interface. It organises programs in a structured manner and provides text editing
facilities. Before using CNC Transfer it is recommended that you read through this
manual.

1.1 Installation
To install CNC Transfer, locate and double-click the installer file then follow the onscreen instructions.

1.2 Running
To run the program, open the Start menu, go to Programs and click CNC Transfer in the
folder of the same name.

1.3 Registration
To enable the registered version of CNC Transfer, load the program then go to the About
menu and click Registration. A dialogue box will appear, in this box you will need to enter
your registration name and key, then click Register. If you have correctly entered the
details you will have full access to CNC Transfer, if not check that you have typed your
registration details exactly as supplied.

2. Using CNC Transfer
2.1 Set Up
When you run CNC Transfer for the first time it will create a default data directory in
C:\CncData. If you would like to use a different location (either because you already have
a data directory elsewhere or because you would like to save to a different location) then
use the Data Location command on the Options menu (see below) to choose another
location.
Before CNC Transfer can be used it must be set up. Use the Edit Customers dialogue box
(see below) to add the names of all the customers that you wish to store programs for.
Use the Edit CNCs dialogue box (see below) to add the technical details of each CNC
machine that will be used. You should test that you have entered the correct settings by
using the Receive and the Send menu commands (see below).
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2.2 Usage

When CNC Transfer is loaded a black editor window will be displayed. Along the top of
the window is the title bar, this shows the name of the currently opened program. Below
the title bar is the menu bar, it allows access to all of CNC Transfer's commands. Below
this is a toolbar that provides convenient access to the most commonly used commands.

2.3 File Menu
The File menu contains the following commands.

2.3.1 Open
This command allows you to open a previously saved program. When the command is
selected the Open Program dialogue box will appear. This dialogue contains a box
labelled Customer, clicking one of the customer names will display a list of programs in
the Program box (if nothing appears it means that there are no programs saved under
that customer name). Selecting one of the programs and clicking the Open button will
open the selected program in the editor.

2.3.2 Save
This command will save any changes made in the editor or the Header dialogue box. If
you are working on an untitled program (for example after using the Import command)
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then the Save Program dialogue box will be displayed (as if you had clicked Save As in the
File menu).

2.3.3 Save As
This command has two main uses. The first use is when you are working on an untitled
program, it allows you to save the program by specifying a customer and program name.
If you want to save your untitled program over the top of an existing program you can
select the customer as normal then choose the program to be overwritten from the
program list.
The second use for the Save As command is to copy a program to another customer.
First, open the program you wish to copy to another customer, then choose the Save As
command. Select the new customer from the list and click Save, the program in the
editor will be copied to the selected customer.

2.3.4 Delete
This command allows you to delete a previously saved program. When the command is
selected the Delete Program dialogue box will appear. This dialogue contains a box
labelled Customer, clicking one of the customers will display a list of programs in the
Program box (if nothing appears it means that there are no programs saved under that
customer). Selecting one of the programs and clicking the Delete button will show a
warning box asking you to confirm your choice. Be careful as deleting a program cannot
be undone.

2.3.5 Close
This command closes the current program.

2.3.6 Import
This command allows you to import an external file containing a program into CNC
Transfer. An Open dialogue box will appear, find the file you wish to import and then
click the Open button. Once you have imported a program from a file it will open in the
editor, you can then use the Save command to save it (see above).

2.3.7 Export
This command allows you to export a program to a text file. A Save As dialogue box will
appear, choose the location you wish to export the program to and enter a filename,
then click the Save button. You will be asked whether you wish to remove encoding data
from the program, selecting Yes will make the exported file easier to read in a standard
text editor but may cause problems when re-importing. Selecting No will export the file
in the same format it was received in.
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2.3.8 Find Program

This command can be used to find a program without knowing which customer it is
stored under. Enter part of the program name in the Program Name box and then click
the Find button. A list of program names containing the text you entered will be
displayed. Clicking one of these programs will display which customer it belongs to in the
Customer Name box. Clicking Open will open the currently selected program in the
editor.

2.3.9 Print
This command allows printing of the current program (including its header information).
Clicking the command shows the Print dialogue box where the printer and the number of
copies to be made can be selected. Press the Print button to start printing.

2.3.10 Print Program Index
This command opens the Print Program Index dialogue box, it allows you to print indexes
of customers and the programs associated with them. You can select customers by
clicking them and can deselect them by clicking a second time. You can use the All and
None buttons to select all customers or deselect all customers respectively. The Each
customer on new page option starts each customer index at the top of a new sheet of
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paper. When you are happy with your choices click Print to bring up the Print dialogue
box where you can choose your printer and the number of copies required. Click the
Print button to start printing.

2.3.11 Print CNC Index
The Print CNC Index command prints a list of each CNC and the options associated with
that machine. Clicking the command shows the Print dialogue box where the printer and
the number of copies to be made can be selected. Press the Print button to start
printing.

2.3.12 Edit Customers

This command shows the Edit Customers dialogue box that allows you to add, edit and
delete customers. To close the Edit Customers dialogue box click the Close button.
To add a customer, click the Add button then enter the name of the new customer.
When you have entered it click Add to accept or Cancel to close without adding the
customer to the list.
To edit a customer, select a customer from the list and then click the Edit button, edit
the name as required then click the Update button. Clicking Cancel will close the Edit
dialogue box without altering the customer name.
To delete a customer, select a customer from the list then click the Delete button, you
will be asked to confirm this decision by clicking the button labelled Yes. If you delete a
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customer all programs associated with that customer will also be removed, this process
cannot be undone so be careful.

2.3.13 Recent Programs
This submenu shows a list of the five most recently opened programs, click an entry to
reopen that program. If you have not yet opened a program this menu item will not
appear.

2.3.14 Exit
This command quits CNC Transfer. If an unsaved program is opened then you will be
asked if you want to save. Click the Yes button to bring up the Save Program dialogue
(see above). Click the No button to exit without saving. Click the Cancel button to keep
CNC Transfer open. It is advisable that you always exit CNC Transfer before turning off
your machine.

2.4 Edit Menu
The Edit menu contains the following commands.

2.4.1 Undo
This command will undo the most recent change in the editor. Pressing Undo again will
restore the most recent change.

2.4.2 Cut
This command will remove the currently highlighted text and place it on the clipboard,
you can then use paste to insert the text in a different position or into a different
program.

2.4.3 Copy
This command will place the currently highlighted text on the clipboard, you can then
use paste to insert the text in a different position or into a different program.

2.4.4 Paste
This command will insert any text on the clipboard at the current cursor position.

2.4.5 Select All
This command selects all text in the current program.

2.4.6 Find
This command opens the Find and Replace dialogue box, any text selected in the editor
will automatically be copied into the Find what box, you can edit this text as normal.
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Click the Find Next button to begin the search. If the text is contained within the editor
then the first occurrence of it will be highlighted, otherwise a message box will inform
you that the text could not be found. To find further occurrences, click the Find Next
button again, click the Find Next command in the Edit menu or press the F3 key.

2.4.7 Find Next
If you have already used the find command then this command will search for the next
occurrence of the text you entered. Find Next will automatically loop around to the top
of the editor when it gets to the bottom. If the Find command has not yet been used
then the Find and Replace dialogue box will show (see above).

2.4.8 Replace
This command displays the Find and Replace dialogue box, it is used to replace one piece
of text with another. Enter the text you wish to be replaced in the box labelled Find what
and the replacement text in the box labelled Replace with, then click either Find Next,
Replace or Replace All. Find Next will search for and highlight the next occurrence of the
Find what text. Replace will replace the currently highlighted Find what text with the
Replace with text, if no match is currently highlighted then Replace will perform a Find
Next instead. Replace All will replace all occurrences of the Find what text with the
Replace with text.

2.4.9 Renumber

This command allows you to renumber a program. The Start box specifies the starting
number for the first line of the renumbered program. The Increment box sets how much
the number should increase by for each line of code. Ticking Restart numbering if original
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numbers restart will preserve any line number restarts in the original program, unticking
this option will ignore any line number restarts in the original program.
The First character box specifies the leading character any current line numbers use (e.g.
if the current line numbers are of the form N0005, N0010, N0015, etc. then you would
specify N in the First character box). If the current lines numbers are purely numeric then
leave this box empty. The Minimum width box allows the line number to be padded with
zeros until it matches the specified width (e.g. setting Minimum width to 4, Start to 0 and
Increment to 5 would output line numbers as 0000, 0005, 0010, etc.). Click the Renumber
button to perform the renumbering.

2.4.10 Header
This command displays any additional information associated with a program and allows
the user to edit this information. All of the boxes can be edited except for the Program
and Customer boxes.

2.5 Transfer Menu
The Transfer menu contains the following commands.

2.5.1 Receive
This command will display the Receive Program dialogue box, this box allows you to
receive programs sent via the serial port from a CNC machine.
You can use the File Name section of the dialogue box to select a customer and then type
or select a program name. You must also choose which CNC you are receiving from. After
choosing a CNC you can fill in any or all of the other boxes with further information
about the setup used with this program. The Clear button will clear this information,
allowing you to start again.
To begin the transfer, click the Receive button. If you chose an existing program and did
not change its name you will be asked to confirm you wish to overwrite it. If you chose
an existing program but changed the name then you will be asked if you want to rename
the existing program or create a new program. Once you have confirmed what you want
to do, the Receive Status dialogue box will open.
You can now tell your CNC machine to begin sending the program. The Receive Status
dialogue box shows how many characters have been received so far. If you wish to end
the process prematurely then clicking the Cancel button will return you to the editor.
When your machine has finished sending the program a message box should appear
telling you the program has been properly received, if this does not happen then click
the Finish button to save the program you have received.
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2.5.2 Send
This command allows you to send the contents of the editor via the serial port to the
selected CNC machine. You should use the Open command (see above) to load the
desired program into the editor first.
If the currently open program has never been sent or received (e.g. it was imported)
then the Choose CNC dialogue box will appear allowing you to select which CNC you are
sending to. If the program has already been sent or received then the CNC will be
automatically chosen (you can change the CNC associated with a specific program by
opening the program then going to the Header command in the Edit menu). Ensure your
CNC machine is set to receive a program before clicking Send. The Send Status dialogue
box will now open, this shows the current progress of the transfer, if you wish to stop
the transfer prematurely then click the Cancel button.

2.5.3 Edit CNCs
This command shows the Edit CNCs dialogue box that allows you to add, edit and delete
CNC profiles.
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Clicking the Add button opens the Add CNC dialogue box. Here you can enter the
relevant data about a particular CNC machine and store that data for future use. First,
enter a name in the box labelled CNC Name, this is compulsory. The other options can
then be set to the required values, when you have finished, click the Add button.
Selecting a CNC then clicking the Edit button allows you to change the current settings
for that CNC profile. Clicking Delete allows you to delete a CNC profile.

2.6 Options Menu
The Options menu contains the following commands.

2.6.1 Data Location
This command allows you to change the location where your CNC programs are stored.
Choose the new location then press OK to confirm. Note this will not move the existing
data directory itself, only the location that CNC Transfer uses. If necessary you can
manually move a data directory using the tools provided by your operating system.

2.6.2 Text Font/Colour
This command shows a Font dialogue box where the font and colour of the text
displayed in the editor window can be chosen.

2.6.3 Background Colour
This command shows a dialogue box where the background colour of the editor window
can be chosen.

2.7 About Menu
The About menu contains the following commands.

2.7.1 Registration
This command allows you to enter a registration code to enable the full version of CNC
Transfer. Enter your registration name and key exactly as supplied, then click the
Register button. After registration this command shows the name of the currently
registered user.

2.7.2 About CNC Transfer
This command shows the current version number of CNC Transfer.

3. Further Details
CNC Transfer uses its own directory to store programs and other relevant data. A regular
backup copy of this directory should be made using the tools provided by your operating
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system or a special purpose backup utility. You should be careful not to delete this
directory unless you want to get rid of all your programs and their associated data.

4. Troubleshooting
Symptoms
A received program is
correct length but
characters appear to
rubbish.
A received program is
the correct length and
characters appear to
rubbish.
Nothing has happened.

the
the
be
not
the
be

Possible Causes
Incorrect parity setting.

Incorrect
setting.

transfer

rate

Incorrect COM port setting.

Incorrect
setting.

handshaking
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Suggested Remedies
Select the correct type of
parity in the Edit CNCs box
according to your CNC
machine’s specifications.
Select the correct transfer
rate, data bits and stop bits
settings in the Edit CNCs
box according to your CNC
machine’s specifications.
Check the machine is
connected to the port
specified in the Edit CNCs
box.
Select
the
correct
handshaking setting in the
Edit CNCs box according to
your
CNC
machine’s
specifications.

